Nice article!
I got a same problem on PhpStorm 9 + Vagrant 1.7.4 + VirtualBox 5.
I regenerated Interpreters with “SSH Credentials” that worked fine 🙂

Thank you.